While trying to authenticate the user trying to login returns the following response from Microsoft.
AADSTS700016: Application with identifier ‘xxxxxxx-22a3-4ef6-xxx-862cc3eb1733’ was not found in the directory ’Customers AD name’. This can happen if the application has not been installed by the administrator of the tenant or consented to by any user in the tenant. You may have sent your authentication request to the wrong tenant.
Endpoint / Log:
- Any auth endpoint
- API Logs
Error renewing access token
Causes
- Wrong client_id
- Application not approved by the mail administrator
Resolution
- If this happens for all customers with account on Office 365 trying to authenticate then ensure the identifier is the Azure client_id - it should be in the format shown in the code block above. A common mistake is copying the wrong value.
- If this happens for specific customers then the customer needs to approve the application via Admin Approval. The mail administrator may wish to improve their approval process to provide a admin consent screen instead of returning the above error.
Resources:
Updated
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